Re: [Forum] ikke hele rpm-pakken, men kun en enkelt fil

From: Esben Nielsen <simlo@phys.au.dk>
Date: Tue Mar 11 2003 - 17:34:17 CET

Jeg vil sige det er trykt at bruge --force --nodep på libavifile. Du skal
dog ikke installere libvorbis-1.0.0rc3 da du allerede har
libvorbis-1.0.0-6mdk,som er nyere.

Hvis du så ikke libavifile virker, må du se på hvad den mangler.
Hvis det f.eks er libvorbis.so så har du den jo, den ligger blot det gale
sted. Det kan du så rette med en link.... Der burde ikke være symboler til
forskel i dine lib's når det kun er ude i patch-level de er ændret, så
programmet/erne burde kunne starte, hvis de(t) altså kan finde filerne.

Esben

On Tue, 11 Mar 2003, Claus Ladekjær Wilson wrote:

> Når jeg støder på følgende, hvad gør jeg så:
> Jeg skal installere libvorbisfile.so.0 for at opfylde afhængighed for
> libavifile0.6-0.6.0-0.20011223.2mdk. Konflikterne er beskrevet nedenunder. Og
> jeg plejer at løse problemet ved at skrive rpm -ivh --force --nodeps. Men
> dels har jeg ikke noget overblik over, hvad det betyder at de tidligere filer
> bliver overskrevet. Dels har jeg kun lyst til at få installeret den ene fil,
> jeg manglede.
> Jeg fandt min rpm-pakke via fr2.rpmfind.net
> Kunne jeg ikke blot få installeret den manglende fil?
> Er der en kommando, så man undgår at overskrive, men som alligevel kan
> installere den manglende fil?
> Er der andre løsninger?
>
> konsol-udskrift:
> ******************************************************
> fejl: afhængighedskrav, der ikke kunne imødekommes:
> libmad.so.0 kræves af libavifile0.6-0.6.0-0.20011223.2mdk
> libqt-mt.so.2 kræves af libavifile0.6-0.6.0-0.20011223.2mdk
> libvorbisfile.so.0 kræves af libavifile0.6-0.6.0-0.20011223.2mdk
> [root@clauswilson dvd_rip]# rpm -ivh libvorbis0-1.0-0.rc3.1mdk.i586.rpm
> Forbereder... ########################################### [100%]
> pakke libvorbis0-1.0-6mdk (som er nyere end libvorbis0-1.0-0.rc3.1mdk) er
> allerede installeret
> filen /usr/lib/libvorbis.so.0 fra installationen af libvorbis0-1.0-0.rc3.1mdk
> skaber konflikt med fil fra pakken libvorbis0-1.0-6mdk
> filen /usr/share/doc/libvorbis0-1.0/AUTHORS fra installationen af
> libvorbis0-1.0-0.rc3.1mdk skaber konflikt med fil fra pakken
> libvorbis0-1.0-6mdk
> filen /usr/share/doc/libvorbis0-1.0/COPYING fra installationen af
> libvorbis0-1.0-0.rc3.1mdk skaber konflikt med fil fra pakken
> libvorbis0-1.0-6mdk
> filen /usr/share/doc/libvorbis0-1.0/README fra installationen af
> libvorbis0-1.0-0.rc3.1mdk skaber konflikt med fil fra pakken
> libvorbis0-1.0-6mdk
> ***********************************************************
> --
> Hilsen / Greetings
> Claus Ladekjær Wilson
> Kirkedammen 19, 2.th
> 8000 Århus C
> tlf. 86112234
> mail: clw@get2net.dk
> ***running Linux Mandrake 8.2 kernel 2.4.18
>
>
> --
> AaLUG Forum liste - Forum@aalug.dk
> http://www.aalug.dk/mailman/listinfo/forum
>
Received on Tue Mar 11 17:34:18 2003

This archive was generated by hypermail 2.1.8 : Tue Jul 19 2005 - 16:04:45 CEST