Re: [Forum] Debian dpkg problem

From: Internetsnedkeren <gunner@internetsnedkeren.dk>
Date: Sun Nov 24 2002 - 18:58:51 CET

On Sunday 24 November 2002 19:30, you wrote:
> Internetsnedkeren wrote:
>
> -[snip ]-
>
> > Kan nogen fortælle mig eller give et link til hvordan jeg kommer af med
> > de problematiske pakker så jeg kan lave min elskede apt-get dist-upgrade
> > ?
>
> http://www.debian.org/releases/stable/i386/release-notes/ch-upgrading.da.ht
>ml#s-aptupgrade
>
> Her er der nogle slimede kneb, jeg har godt nok ikke provet dem, de er i
> dette afsnit
>
> 3.5 Opgradering direkte med apt-get (anbefales ikke)
Jeg har muligvis brugt den forkert. Jeg forsøger ikke at opgradere en dist
men at dagligt vedligeholde den.
det skulle så være apt-get upgrade.

Men det giver også de fejl:
Sorry, but the following packages have unmet dependencies:
  libc6: Depends: libdb1-compat but it is not installable
  libc6-dev: Depends: libc6 (= 2.2.5-11.2) but 2.3.1-3 is to be installed
  libgtk-common: Depends: libgtk2.0-common (= 2.0.2-5woody1) but it is not
going to be installed
  libgtk2.0-0: Depends: libfreetype6 (>= 2.1.1-1) but 2.0.9-1 is to be
installed
               Depends: libpng12-0 but it is not installable
  libpango1.0-0: Depends: libpango-common but it is not going to be installed
                 Depends: libfreetype6 (>= 2.1.1-1) but 2.0.9-1 is to be
installed
  locales: Depends: glibc-2.2.5-11.2
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify
a solution).

Så hvis jeg gør noget ved dette... altså siger 'apt-get -f install' får jeg
ret voldsomme ting at vide ("Do only this if absolutely sure you know what
you do ...)
men jeg vil gerne fjerne disse ting da jeg føler de blokerer for min
apt-get upgrade.
mvh Gunner
Received on Sun Nov 24 18:58:45 2002

This archive was generated by hypermail 2.1.8 : Tue Jul 19 2005 - 16:04:27 CEST