Re: [Forum] Debian dpkg problem

From: Svend Erik Venstrup <venstrup@mail1.stofanet.dk>
Date: Sun Nov 24 2002 - 18:16:00 CET

Internetsnedkeren wrote:

> Hej

-[snip]-

> Reading Package Lists... Done
> Building Dependency Tree... Done
> You might want to run `apt-get -f install' to correct these.

Jeg er godtnok debian newbie, men jeg ville prove med:
apt-get -f install xxxx

Prov at se paa:

file:///usr/share/doc/apt/guide.html/index.html

samt

file:///usr/share/doc/apt/offline.html/index.html

de har hjulpet mig af og til

Sorry, but the following packages have unmet dependencies:
 libc6: Depends: libdb1-compat but it is not installable

> libc6-dev: Depends: libc6 (= 2.2.5-11.2) but 2.3.1-3 is installed

versionsnumre: ^^^^^^^^^^^^^^^^^^^^^^

>
> libgtk2.0-0: Depends: libgtk-common but it is not installed
> Depends: libfreetype6 (>= 2.1.1-1) but 2.0.9-1 is installed

> Depends: libpng12-0 but it is not installable

> libpango1.0-0: Depends: libpango-common but it is not installed

> Depends: libfreetype6 (>= 2.1.1-1) but 2.0.9-1 is installed
> locales: Depends: glibc-2.2.5-11.2
> E: Unmet dependencies. Try using -f.
>
> Nu vil jeg gerne slippe af med de ovennævnte så jeg igen kan lave min
> apt-get dist-upgrade uden problemer. Jeg har prøvet mange ting, som ikke
> virkede:
> apt-get remove libc6
> apt-get remove libpango1.0-0_1.0.5-3_i386.deb
> dpkg -r libc6_2.3.1-3_i386.deb
> og lignende men der kommer hele tiden fejl.
>
> Kan nogen fortælle mig eller give et link til hvordan jeg kommer af med de
> problematiske pakker så jeg kan lave min elskede apt-get dist-upgrade .

--
Hilsen svend
)-;>/
Received on Sun Nov 24 17:08:24 2002

This archive was generated by hypermail 2.1.8 : Tue Jul 19 2005 - 16:04:27 CEST