[Forum] Debian dpkg problem

From: Internetsnedkeren <gunner@internetsnedkeren.dk>
Date: Sun Nov 24 2002 - 15:04:39 CET

Hej
Jeg forsøgte installation af følgende pakker:
libpango1.0-0_1.0.5-3_i386.deb
libart-2.0-2_2.3.10-3_i386.deb
libswfdec0_0.1.2-3_i386.deb
libatk1.0-0_1.0.3-2_i386.deb
swf-player_0.1.2-3_i386.deb
libc6_2.3.1-3_i386.deb
xlibs_4.2.1-3_i386.deb
libglib2.0-0_2.0.7-1_i386.deb
zlib1g_1.1.4-6_i386.deb
libgtk2.0-0_2.0.8-2_i386.deb
på min woody. De ville ikke installere.

Når jeg nu efterfølgende vil lave apt-get dist-upgrade får jeg følgende
besked:

Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
Sorry, but the following packages have unmet dependencies:
  libc6: Depends: libdb1-compat but it is not installable
  libc6-dev: Depends: libc6 (= 2.2.5-11.2) but 2.3.1-3 is installed
  libgtk2.0-0: Depends: libgtk-common but it is not installed
               Depends: libfreetype6 (>= 2.1.1-1) but 2.0.9-1 is installed
               Depends: libpng12-0 but it is not installable
  libpango1.0-0: Depends: libpango-common but it is not installed
                 Depends: libfreetype6 (>= 2.1.1-1) but 2.0.9-1 is installed
  locales: Depends: glibc-2.2.5-11.2
E: Unmet dependencies. Try using -f.

Nu vil jeg gerne slippe af med de ovennævnte så jeg igen kan lave min
apt-get dist-upgrade uden problemer. Jeg har prøvet mange ting, som ikke
virkede:
 apt-get remove libc6
 apt-get remove libpango1.0-0_1.0.5-3_i386.deb
 dpkg -r libc6_2.3.1-3_i386.deb
og lignende men der kommer hele tiden fejl.

Kan nogen fortælle mig eller give et link til hvordan jeg kommer af med de
problematiske pakker så jeg kan lave min elskede apt-get dist-upgrade ?

mvh Gunner
Received on Sun Nov 24 15:04:36 2002

This archive was generated by hypermail 2.1.8 : Tue Jul 19 2005 - 16:04:26 CEST