[Forum] Re: [Forum] opsætning af tre ethernet

From: Bo Bjerre <post@Bjerre-Technology.dk>
Date: Fri Apr 12 2002 - 08:23:14 CEST

> Foerts, hvad siger "cat /prog/sys/net/ipv4/ip_forward". Hvis den ikke
> siger 1, er her i alle fald et problem. Loes det ved at echo 1 deri.
> Det er nok ikke det, der er problemet.
>
> Ellers, er det nok dine routes, som er sat forkert op. Det er en mere
> spaendende oplevelse. Hvis dine netkor staar paa hver sit subnet (jeg
> gaetter paa det drejer sig om internet, intranet og DMZ?), er du naesten
> koerende. Check med "route" om der er en route paa hvert subnet, som
> peger paa det korrekte netkort. Default route skal pege paa internet.
> Det lyder lidt somom du har en default route, som peger paa eth1, og
> mangler de to (mindst) andre.

Jeg har sat ipv_forward til "1"

routes siger at der er er et subnet på hver interface, og det ser ud som
forventet
default er ethh0, som er min stofa. Denne er osse sat til gateway.

? er det fordi etho er sat til getewaydevice at den bliver default, eller
hvem har bestemt det ?

jeg forstår bare ikke at jeg ikke kan pinge hvert af de tre interfaces
udefra, hvis jeg tilslutter dem til mit intranet.

-din antagelse om anvendelsen af de 3 netporte er rigtig.

Min firewall er meget enkel, idet den kun omfatter eth0 og eth1, og ingen
adgang udefra til selve linuxmaskinen. Derfor er der ikke sat nogen regler
for INPUT og OUTPUT, men kun FORWARD

------------------
PATH=/sbin

iptables -P INPUT DROP
iptables -F INPUT
iptables -P OUTPUT DROP
iptables -F OUTPUT

iptables -P FORWARD DROP
iptables -F FORWARD

iptables -A FORWARD -i eth0 -o eth1 -m state --state ESTABLISHED,RELATED -j
ACCEPT

iptables -A FORWARD -i eth1 -o eth0 -j ACCEPT
iptables -A FORWARD -j LOG

iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
----------------------------

Bo //
Received on Fri Apr 12 08:19:43 2002

This archive was generated by hypermail 2.1.8 : Tue Jul 19 2005 - 16:03:37 CEST