Re: [Forum] usb og luk-ned-problemer

From: Claus Ladekjær Wilson <clw@get2net.dk>
Date: Wed Jan 02 2002 - 21:31:55 CET

Allerførst tak for en udførlig besked til mig om hvad jeg skal gøre!

Jeg kan desværre ikke finde det sted i lukned-processen, hvor den går fast,
men efter hukommelsen er det:
Disconnect from usb bus number 1
Disconnect from usb bus number 2
Disconnect from usb bus number 3

(> Prøv at lave en `lsmod` og derefter en `rmmod modulnavn` og derefter en
> `dmesg`... og smid det relevante output her på listen.)
dmesg output:
--klip-----------------------------------------------------------------
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.268 $ time 18:20:46 Dec 22 2001
usb-uhci.c: High bandwidth mode enabled
PCI: Found IRQ 5 for device 00:04.2
usb-uhci.c: USB UHCI at I/O 0xd400, IRQ 5
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: v1.268:USB Universal Host Controller Interface driver
hub.c: USB new device connect on bus1/1, assigned device number 2
usb.c: USB device 2 (vend/prod 0x3f0/0x401) is not claimed by any active
driver.
hub.c: USB new device connect on bus1/2, assigned device number 3
usb.c: USB device 3 (vend/prod 0x781/0x2) is not claimed by any active driver.
usb.c: registered new driver usbscanner
scanner.c: 0.4.6:USB Scanner Driver
Initializing USB Mass Storage driver...
usb.c: registered new driver usb-storage
usb-uhci.c: interrupt, status 2, frame# 263
scsi1 : SCSI emulation for USB Mass Storage devices
  Vendor: SanDisk Model: ImageMate II Rev: 1.30
  Type: Direct-Access ANSI SCSI revision: 02
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 3
USB Mass Storage support registered.
Attached scsi removable disk sda at scsi1, channel 0, id 0, lun 0
SCSI device sda: 125441 512-byte hdwr sectors (64 MB)
sda: Write Protect is off
 /dev/scsi/host1/bus0/target0/lun0: p1
MSDOS FS: IO charset iso8859-1
MSDOS FS: Using codepage 850
VFS: Disk change detected on device sd(8,1)
Device busy for revalidation (usage=1)
MSDOS FS: IO charset iso8859-1
MSDOS FS: Using codepage 850
usb.c: USB disconnect on device 1
usb.c: USB disconnect on device 2
---klip-------------------------------------------------------------

Når jeg udfører kommandoen modprobe og rmmod usb-uhci manuelt er der ingen
problemer. Det er først, når jeg beder computeren gøre det (via Mandrake
Control Panel).

(> Prøv at lave en `lsmod` og derefter en `rmmod modulnavn` og derefter en
> `dmesg`... og smid det relevante output her på listen.)
Det er en hp-brænder IDE, der kører under SCSI-emulation. Den har nummer 8200.

dmesg:
---klip---------------------------------------------------------
hdd: Hewlett-Packard CD-Writer Plus 8200a, ATAPI CD/DVD-ROM drive
hda: 26688576 sectors (13665 MB) w/512KiB Cache, CHS=1661/255/63, UDMA(33)
hdc: Disabling (U)DMA for WDC AC33100H
hdc: 6185088 sectors (3167 MB) w/128KiB Cache, CHS=6136/16/63
hdd: ATAPI 32X CD-ROM CD-R/RW drive, 4096kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
ide-floppy driver 0.97.sv
Partition check:
 /dev/ide/host0/bus0/target0/lun0: p1 p2 < p5 p6 p7 p8 p9 p10 > p4
 /dev/ide/host0/bus1/target0/lun0: [PTBL] [767/128/63] p1 p2 < p5 >
---klip--
SCSI subsystem driver Revision: 1.00
---klip--
imm: Version 2.05 (for Linux 2.4.0)
SCSI subsystem driver Revision: 1.00
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
---klip-----------------------------------------------------------

foruden en ide-scsi cdrom-brænder har jeg loaded imm-modul, fordi jeg
indimellem kører IomegaZipDisk.

Jeg kører kerne 2.4.16

Hvordan mounter jeg scsi0 device (som sidder på /dev/hdd)

Jeg håber, at dette var nok, og at nogle kender et godt svar!

**********************************************************************************
onsdag den 2. januar 2002 15:49 skrev du:
> On Tue, 2002-01-01 at 21:07, Claus Ladekjær Wilson wrote:
> > Jeg har installeret en SanDisk-læser, og siden har jeg haft
> > luknedproblemer,
>
> Luknedproblemer? Hvorledes? Beskriv dem, ellers er det nærmest umuligt
> at hjlæpe...
>
> > hvis usb-modulet er loadet fra start. Hvis jeg derimod via
> > Mandrake>ControlPanel>Tjenester lukker usb-modulet ned, lukker maskinen
> > ned som før.
>
> Prøv at lave en `lsmod` og derefter en `rmmod modulnavn` og derefter en
> `dmesg`... og smid det relevante output her på listen.
>
> > Problem to: Mit cdrom-drev (som også er brænder) lå tidligere på
> > /dev/scd0.
>
> Er det en SCSI-brænder? Eller er det en IDE-brænder der kører under
> SCSI-emulation?
>
> > Er der nogen, der har en idé om, hvor det er forsvundet hen, og om hvad
> > det er for en ordning, der har flyttet det fra /dev/hdd? Der må vel være
> > et link et eller andet sted.
>
> "Fra /dev/hdd"? Skrev du ikke lige at den førhen lå under /dev/hdd??
>
> Du kan bruge kommandoen `dmesg` til at gennemse kernens meddelelser; kig
> efter linien hvor den detekterer dit CD-ROM drev, der kan du se hvilket
> major/minor (hvilken /dev entry), det er associeret med.
>
> > ***running Linux Mandrake 8.1 kernel 2.4.8 og kernel 2.4.16
>
> Hvilken kerne kører du? Hvilken kerne har du problemer med?
>
> Mvh
> ./Brix

-- 
Hilsen / Greetings
Claus Ladekjær Wilson
Kirkedammen 19, 2.th
8000 Århus C
tlf. 86112234
mail: clw@get2net.dk
***running Linux Mandrake 8.1 kernel 2.4.8
Received on Wed Jan 02 21:31:55 2002

This archive was generated by hypermail 2.1.8 : Tue Jul 19 2005 - 16:03:21 CEST