Re: [Forum] unresolved symbols

From: Svend Erik Venstrup - Nielsen <venstrup@mail1.stofanet.dk>
Date: Fri Mar 09 2001 - 09:47:15 CET

Martin Petersen wrote:

> Hej
>
> Jeg har med succes tidligere kompilret og installeret nvidia's kernel-driver,
> men nu får jeg fejl fra 'insmod' (den eneste forskel er, at jeg har
> installeret de nyeste modutils, 2.4.3).
>
> Er der nogen der kan sige mig hvad alle disse 'unresolved symbols' kan
> skyldes:
> depmod: *** Unresolved symbols in /lib/modules/2.4.2/video/NVdriver
> /lib/modules/2.4.2/video/NVdriver: unresolved symbol pci_write_config_byte

-- [ Snip ]--

> make: *** [package-install] Error 255

Hej Martin
Uden at vilde gøre mig til expert i kerlel´s og dennes instalation, er her mit
forslag til en løsningsmodel:
Jeg tror at du fejlagtigt har fået instaleret en del af noget med video
/lib/modules/2.4.2/video/NVdriver: dette modul mangler
nogle af sine procedure el. HW-instillinger eks:[pci_write_config_byte].
Sansyæigvis dem alle, dette betyder at der er installeret en del af en
video-et_el.andet.
Jeg har set [disse_former_for_henvisninger] et el andet sted i noget
udviklingsmateriale, for video håndtering. Det kan også være data som modulet
henter fra faste HW- instillinger.

Løsning:
A: udersøg /lib/modules/2.4.2/video/NVdriver: Se efter datoer, de skal være
ens, de er kompejleret samme dag.
    Hvis de ikke er det er der muligvis en fejl

B: Find File listen på CD og sammenligm /lib/modules/2.4.2/video/NVdriver mrd
filelisten

Jeg er ikke helt færdig

Beklager

Hilsen / Regards Svend

(-;>/ \<;-)

> På forhånd tak
> Martin Petersen
>
> --
> AaLUG Forum liste - Forum@aalug.dk
> http://www.aalug.dk/mailman/listinfo/forum
Received on Fri Mar 09 09:39:54 2001

This archive was generated by hypermail 2.1.8 : Tue Jul 19 2005 - 16:01:59 CEST