[Forum] 3D-accelleration med S3 savage4

From: Bjarke Dahl Ebert <ebert@irisa.fr>
Date: Mon Oct 23 2000 - 13:02:28 CEST

Hej Forum.

Jeg er i færd med at få den frie flysimulator FlightGear
(www.flightgear.org) til at compilere på min Linux-maskine.
Den baserer sig på OpenGL, så jeg skal have installeret et OpenGL
library til mit grafikkort. Det er et S3savage4 kort.

Jeg har installeret Mesa (www.mesa3d.org), som i praksis er en
implementation af OpenGL API'et (selvom de ikke lover, at den er helt
conforming). Og så har jeg installeret GLUT, som indeholder en række
demoer, så jeg kan se at det faktisk virker. Men nogen ting går så
langsomt, at det er ubrugeligt.
Jeg er nu kommet frem til, at det skyldes, at Mesa implementerer OpenGL
i software og snakker gennem X11, hvor X11-serveren så snakker
2D-accelleration til mit savage4 kort -- dvs. 3D-accellerationen
udnyttes overhovedet ikke.
Mesa kan godt køre på 3D hardware, men bare ikke på S3 -- i hvert fald
ikke under Linux. Derimod skulle Voodoo kortene være fint understøttet.

Kan det virkeligt passe, at jeg skal ud og købe et Voodoo-kort, når nu
jeg har et fint S3?

Er der nogen, der kender til andre OpenGL implementationer, der kan
anvende S3 savage4 under Linux?
Jeg har fundet noget til S3 savage3D, men savage3D og savage4 er vist
ikke kompatible....

Hjææælp mig stakkels arme mand... Hvad skal jeg gøre? Brokke mig til S3
over at de ikke kører OpenGL på Linux? :-)

Mvh. Bjarke Ebert

-- 
IRISA-INRIA, Campus de Beaulieu, 35042 Rennes cedex, France
Home page: http://www.irisa.fr/compose/ebert/
Received on Mon Oct 23 13:02:33 2000

This archive was generated by hypermail 2.1.8 : Tue Jul 19 2005 - 16:01:38 CEST