[Forum] Re: [Forum] Lige to små spgs....

From: Morten Liebach <morten@hotpost.dk>
Date: Wed Sep 27 2000 - 22:14:38 CEST

On 27, Sep, 2000 at 08:04:30PM +0200, Thomas Kristensen wrote:
> Hej igen alle
>  
> Jeg kommer lige med et teoretisk spørgsmål og med et problem
>  
> teori:
> Hvorfor kan linux (altså X) ikke vises nogle ordentlige skrifttyper i f.eks.
> netscape. Hvis man f.eks. har en skrifttype på 10px i ert html doc, ja så går
> den helt amok! Hvorfor kan den ikke vise, tja, er det postscript?, skrifttyper
> rigtigt? Er det patenteret teknologi der er problemet...

Nej, det er gammel tek!
X protokollen er vist fra 1987, og den giver ikke mulighed for
anti-aliasing. TrueType fonte kan du køre, enten gennem den nyeste
X-4.0, eller ved at bruge en truetype fontserver (xfstt eller xfs-xtt,
jeg bruger selv den første). Nettet ser _meget_ bedre ud i en netscape
der har adgang til en arial truetype font, så det er nok det der er
løsningen på dit problem, for default i X er rådden at se på.

Lidt flere fif til netscape; sæt dette i din ~/.Xdefaults:

 ! For better fonts in Netscape
 Netscape*documentFonts.xResolution*iso-8859-1: 100
 Netscape*documentFonts.yResolution*iso-8859-1: 100

 ! Restrict the range of size increments allowed by <font size=n>
 directives to
 ! the range 80% - 120% rather than 50% - 210%. Default increment is 20.
 ! KMSelf Wed Dec 29 15:47:57 PST 1999
 Netscape*documentFonts.sizeIncrement: 05

 ! Clean up the fscking toolbar
 Netscape*toolBar.search.isEnabled: false
 Netscape*toolBar.destinations.isEnabled: false
 Netscape*toolBar.myshopping.isEnabled: false
 Netscape*toolBar.viewSecurity.isEnabled: true
 Netscape*toolBar.print.isEnabled: true
 Netscape*toolBar.home.isEnabled: true

 ! Repair some other brain damage
 Netscape*useStdoutDialog: false
 Netscape*useStderrDialog: false
 Netscape*noAboutSplash: true

 ! Fonts -- dialogs and such
 Netscape*attachmentProps*XmLabelGadget.fontList: fixed
 Netscape*AddressBook*mainform.fontList: fixed
 Netscape*XmLGrid*fontList: fixed
 Netscape*attachItemLabel*fontList: fixed
 Netscape*prefs*fontList: fixed
 Netscape*statusBar*fontList: fixed

Et tip fra Karsten M. Self fra debian-user mailinglisten.

> problem:
> Jeg skal i undervisningen af nogle elever på en ungdomsskole sætte en apache
> server op med php. Serveren har jeg selv, og alt virker normalt i den. Men jeg
> kan ikke komme i kontakt med de andre computere på det netværk jeg kobler mig
> på. Der er en hub jeg smider mig på, jeg har tjekket de andre computeres
> undernetmaske, og har forsøgt at sætte min til det samme og bare ip'en
> 192.168.0.*** (forskellige brugt)
> De andre computere bruger dhcp, men heller ikke det virker...
> Det som de andre computere skal, er bare at kunne komme i kontakt med den
> computer jeg selv har sat op igennem http (altså, bare en alm. tcp/ip
> forbindelse)
> Er der nogen der har en ide til hvad problemet kan være?
> Det er en rødhætte 6.2

Jeg har ikke, men det var måske rart med lidt flere detaljer til de
mange der er klogere end jeg mht. netværk ...

Hilsen
                Morten

-- 
Morten Liebach <morten@hotpost.dk> || http://home1.stofanet.dk/liebach
Lleah about Kibo on alt.religion.kibology:
``He's a diety, after all, duh.'' ... Yummy!?
Received on Wed Sep 27 22:15:32 2000

This archive was generated by hypermail 2.1.8 : Tue Jul 19 2005 - 16:01:33 CEST