Re: SV: [Forum] smadret MBR?

From: Morten Liebach <morten@hotpost.dk>
Date: Wed Feb 09 2000 - 11:24:39 CET

On Wed, 09 Feb, at 09:05, Johannesen,Bjarke BZJ wrote:
> jeg kører ikke med bootflags på nogle af mine partitions og kan udemærket
> boot på dem...
> >
> > Kunne det tænkes at du muligvis har fået fjernet bootable-flag fra din
> > disk??
> > >
> > > Min MBR er smadret, og det er jeg ked af :-(
> > >
> > > Jeg har tjekket min lilo.conf og kørt lilo flere gange, men når jeg
> > > forsøger at boote skriver den "3FA:" og så sker der ikke mere.
> > >
> > > Jeg aner ikke hvad der sker, nogen ideer?

Problemet er løst. Jeg brugte dd:

        oenone:~# dd if=/dev/null of=/dev/hda bs=512 count=1

Det skulle overskrive de første 512 byte med nuller. Så tjekkede jeg
lilo.conf endnu engang, kørte lilo, og så rebootede jeg, og voila!, alt
er godt :-))

Nu kommer den tricky del, jeg vil ha' Win98 lagt ind på /dev/hda1,
OpenBSD på /dev/hda2.

 Jeg ved det kan lade sig gøre, har gjort det en gang før, men glemt
hvordan. Hvis der er nogen der lige ved hvordan så skriv endelig, men
ellers finder jeg nok ud af hvordan det var jeg gjorde engang i løbet
af de næste dage...

 It's good to be geek ;-)

                Morten Liebach

PS: min diskgeometri som den ser ud nu:

Name Flags Part Type FS Type [Label] Size (MB)
--------------------------------------------------------------
hda1 Boot Primary Win95 FAT32 1019.94
hda2 Primary OpenBSD 1891.82
hda3 Primary Linux ext2 /home 1299.60
hda5 Logical Linux ext2 / 74.03
hda6 Logical Linux ext2 /usr 1719.09
hda7 Logical Linux ext2 /var 312.57
hda8 Logical Linux swap 131.61

Så der er plads nok, men hda1 & hda2 er tomme nu...
hda3 er totalt fredet, jeg har ingen mulighed for backup af de data!

-- 
In the future everything was up to itself.
Received on Wed Feb 09 11:24:39 2000

This archive was generated by hypermail 2.1.8 : Tue Jul 19 2005 - 16:00:38 CEST